Problem connecting to RPC server + related ASP and DCOM issues

Giganews Newsgroups
Subject: Problem connecting to RPC server + related ASP and DCOM issues
Posted by:  Trilix (Tril…@discussions.microsoft.com)
Date: Thu, 1 Feb 2007

Hi,

This is a Citrix question, but maybe Windows is the cause of the problem.

I'm getting the following errors on my WI (web interface) server :
Some Web Interface configuration servers could not be contacted.
The RPC server cannot be contacted on server BETESSEN080P

This is how the WI server is configured:

* I've installed Web Interface 4.0 on win2000 server. (= BE-TES34)
* ASP v1.1.4322 installed with the .net framework 1.1
* MS J# installed from the citrix cd-rom

I've created a site in the Access Suite console for PNAgent

* WI configuration server defined is my primary PS server
* Added my primary PS server as PS server configuration server
* In the "Manage server farms" I've included my 2 PS servers
* My primary PS server = BETESSEN080P

Here's some extra info I found in the eventlog of the WI server (BE-TES34) :

DCOM got error "General access denied error " from the computer BETESSEN080P
when attempting to activate the server: {EC141AA5-2FCB-4A70-BBA0-025B6A2A626E}

aspnet_wp.exe could not be started. The error code for the failure is
80004005. This error can be caused when the worker process account has
insufficient rights to read the .NET Framework files. Please ensure that the
.NET Framework is correctly installed and that the ACLs on the installation
directory allow access to the configured account.

Although it says that it cannot start the aspnet_wp.exe service, it can be
started with no problem in the services.msc. ASPNET account is used. It also
appears in the process tab as aspnet_we.ex (without e)

I've tried everything I've found on google (at least I think...) and can't
get it to work.
I can ping the PS servers.

Please help, because this is getting frustrating.

Replies