Figuring out which version of .NET an assembly is dependent on

Giganews Newsgroups
Subject: Figuring out which version of .NET an assembly is dependent on
Posted by:  michael (micha…@discussions.microsoft.com)
Date: Thu, 12 Feb 2009

I have a .NET app (which uses WPF) that uses some 3rd party assemblies. When
I compile, I select the .NET 3.5 setting. However, at deployment (which I do
via ClickOnce), it says that my app is dependent on .NET 3.5 SP1.

There's nothing about the code I'm writing that is dependent on .NET 3.5
SP1, so I assume that it's one of the libraries that I'm using. Is there a
way to identify what a library is dependent on? (Of course I could remove
libraries one at a time but I wanted a way to actually see which version of
.NET a given assembly requires)

--
Michael

Replies